Вышли новые версии MikroTik #RouterOS
RouterOS 7 Stable: 7.23.2
RouterOS 7 Long-term: 7.21.5
RouterOS 6 Long-term: 6.49.20
У всех в changelog'е:
то есть исправили что-то связанное с безопасностью.
Домашних пользователей не должно заафектить, но рекомендуют обновиться.
Следуем рекомендациям?
RouterOS 7 Stable: 7.23.2
RouterOS 7 Long-term: 7.21.5
RouterOS 6 Long-term: 6.49.20
У всех в changelog'е:
!) fixed a service security issue, home user with default config not affected, but we recommend the upgrade for all users regardless;
то есть исправили что-то связанное с безопасностью.
Домашних пользователей не должно заафектить, но рекомендуют обновиться.
Следуем рекомендациям?
🔥8
открыл для себя новую запись ASN.
RFC5396 : Формат ASdot или ASdot+ (они немного разные).
asplain - простая десятичная запись ASN в виде одного числа.
asdot — формат, разбивающий 32‑битный ASN на две 16‑битные части: «старшую» и «младшую», разделённые точкой. То есть каждые 16 бит интерпретируем как отдельное число.
Оказалось, что пользоваться 32-битными ASN бывает комфортнее в ASdot. 😎
Вот пример для таблицы с диапазонами ASN в формате ASplain
А вот тоже самое, но в формате ASdot
Итого, если вы использовали приватную 16-битную ASN
то вы также можете использовать
С другой стороны приватные ASN вида
P.S.
в комментариях предлагаю привести примеры как ИИ переводят эти диапазоны из asplain в asdot (мне пока все опрошенные соврали)
RFC5396 : Формат ASdot или ASdot+ (они немного разные).
asplain - простая десятичная запись ASN в виде одного числа.
asdot — формат, разбивающий 32‑битный ASN на две 16‑битные части: «старшую» и «младшую», разделённые точкой. То есть каждые 16 бит интерпретируем как отдельное число.
Оказалось, что пользоваться 32-битными ASN бывает комфортнее в ASdot. 😎
Вот пример для таблицы с диапазонами ASN в формате ASplain
asplain | comment
0 | reserved RFC7607
1 – 23455 | global
23456 | reserved AS_TRANS
23457 – 64495 | global
64496 – 64511 | Reserved RFC5398
64512 – 65534 | Reserved for Private Use RFC6996
65535 | Reserved RFC7300
65536 – 65551 | Reserved for use in documentation and sample code RFC5398
65552 – 131071 | Reserved
131072 – 4199999999 | global
4200000000 – 4294967294 | Reserved for Private Use RFC6996
4294967295 | Reserved RFC7300
А вот тоже самое, но в формате ASdot
asdot | comment
0 | Reserved RFC7607
1 – 23455 | global
23456 | Reserved AS_TRANS
23457 – 64495 | global
64496 – 64511 | Reserved RFC5398
64512 – 65534 | Reserved for Private Use RFC6996
65535 | Reserved RFC7300
1.0 – 1.15 | Reserved for use in documentation and sample code RFC5398
1.16 – 1.65535 | Reserved
2.0 – 64086.59903 | global
64086.59904 – 65535.65534 | Reserved for Private Use RFC6996
65535.65535 | Reserved RFC7300
Итого, если вы использовали приватную 16-битную ASN
64555 ,то вы также можете использовать
64555.*****С другой стороны приватные ASN вида
4 2** *** *** , тоже достаточно наглядны.P.S.
в комментариях предлагаю привести примеры как ИИ переводят эти диапазоны из asplain в asdot (мне пока все опрошенные соврали)
IETF Datatracker
RFC 5396: Textual Representation of Autonomous System (AS) Numbers
A textual representation for Autonomous System (AS) numbers is defined as the decimal value of the AS number. This textual representation is to be used by all documents, systems, and user interfaces referring to AS numbers. [STANDARDS-TRACK]
🔥1
MTik.pro новости
в комментариях предлагаю привести примеры как ИИ переводят эти диапазоны из asplain в asdot (мне пока все опрошенные соврали)
Кто в теме про ИИ, почему ИИ-шки не умеют в обычные арифметические операции?
Forwarded from Типичный Сисадмин
В любимой прошивке раскопали шикарную RCE. Вся магия происходит в демоне
odhcpd, который отвечает за выдачу IPv6-адресов. И да, по дефолту этот демон крутится с правами root Разрабы допустили классическое переполнение фиксированного 512-байтового стекового буфера (
pdbuf). Чтобы взломать роутер, атакующему не нужна авторизация. Достаточно плюнуть снаружи всего один нужный UDP-пакет на 547 порт.На Гитхабе подробно расписали сразу два независимых вектора атаки в функциях
build_ia() и dhcpv6_ia_handle_IAs(). Хакер отправляет DHCPv6 REQUEST, в который напихано аномальное количество опций (например, 22 невалидных
IA_PD и параметр RECONF_ACCEPT). Демон начинает формировать ответ со статусами ошибок, но забывает проверить, осталось ли место в буфере. В итоге ответ тупо пишется за пределы выделенной памяти, а переменная buflen уходит в integer underflow (переполнение через ноль). И это довольно фатально... если на взрослых Linux-серверах от такого спасает защита стека и рандомизация памяти, то на роутерах эти механизмы часто отключены ради экономии ресурсов. В итоге обычное переполнение превращается в гарантированное удаленное выполнение кода. Готовые питоновские скрипты с эксплойтами уже лежат в паблике.
Уязвимость закрыли в свежих релизах 24.10.8 и 25.12.5. Кстати, ветка 24.10 в сентябре этого года всё - заканчивается, так что лучше сразу накатывать 25.12. Заодно апдейт закроет еще пачку веселых багов, вроде HTTP request smuggling в веб-морде
uhttpd и утечек памяти.Ну или если IPv6 вам физически не нужОн, то вырубайте его на интерфейсах от греха подальше. Меньше протоколов - крепче сон
Типичный
Please open Telegram to view this post
VIEW IN TELEGRAM
😱3 1 1
MTik.pro новости
Вышли новые версии MikroTik #RouterOS RouterOS 7 Stable: 7.23.2 RouterOS 7 Long-term: 7.21.5 RouterOS 6 Long-term: 6.49.20 У всех в changelog'е: !) fixed a service security issue, home user with default config not affected, but we recommend the upgrade for…
Экстренные Обновления #MikroTIk #RouterOS
Снова что-то серьёзное!
RouterOS 7 Stable: 7.24.2
RouterOS 7 Long-term: 7.23.4
RouterOS 6 Long-term: 6.49.21
В changelog'е:
Снова что-то серьёзное!
RouterOS 7 Stable: 7.24.2
RouterOS 7 Long-term: 7.23.4
RouterOS 6 Long-term: 6.49.21
В changelog'е:
This is an important security update. Most configurations are not at risk, but upgrading is highly recommended. To give time to update your systems, we are not currently publishing detailed information.
*) btest - improve stability;
*) console - improve stability;
*) fetch - improve stability of the TFTP client;
*) snmp - improve stability of SNMP;
*) snmp - properly validate password length when applying configuration;
*) ssh - refactor SSH internal processes and improved system stability;
*) system - improve stability;
*) system - updated certificate for Windows executable signing;
*) dhcp - improve stability of DHCP handling;
*) disk - improve stability of the SMB server;
*) ipsec - improve IKE handshake stability;
*) tunnel - fixed stability issue caused by a misconfigured routing loop under bridge (introduced in v7.22);
*) webfig - improve stability;
*) www - improve stability;
👍1
А по версиям #RouterOS
до RouterOS 7.21.4
уже доступно описание CVE-2026-39042
An issue in MikroTik RouterOS 7.21.x before
v.7.21.4 and 7.22.x before v.7.22.2 allows a remote attacker to cause a
denial of service via the unflatten() function in libumsg.so."
https://zakpatrik.cz/blog/finding-an-integer-overflow-in-mikrotik-routeros-core-ipc-library
до RouterOS 7.21.4
уже доступно описание CVE-2026-39042
An issue in MikroTik RouterOS 7.21.x before
v.7.21.4 and 7.22.x before v.7.22.2 allows a remote attacker to cause a
denial of service via the unflatten() function in libumsg.so."
https://zakpatrik.cz/blog/finding-an-integer-overflow-in-mikrotik-routeros-core-ipc-library
Patrik Žák
Finding an Integer Overflow in MikroTik RouterOS Core IPC Library — Patrik Žák
A pre-authentication integer overflow in nv::message::unflatten() — the core deserialization function shared by every RouterOS service — affecting all RouterOS 7.x versions in default configuration. Assigned CVE-2026-39042 by MITRE, confirmed and fixed by…
👍3
MTik.pro новости
Экстренные Обновления #MikroTIk #RouterOS Снова что-то серьёзное! RouterOS 7 Stable: 7.24.2 RouterOS 7 Long-term: 7.23.4 RouterOS 6 Long-term: 6.49.21 В changelog'е: This is an important security update. Most configurations are not at risk, but upgrading…
CVE на последнее обновление #MikroTik подъехало: CVE-2026-67276
И это критическая уязвимость аж на 9.2 (из 10).
Суть уязвимости
Проблема заключается в недостаточной проверке публичных ключей при аутентификации по протоколу SSH. Если супер кратко, то злоумышленник может установить SSH соединение не имея приватного ключа. 🤯
И это критическая уязвимость аж на 9.2 (из 10).
Суть уязвимости
Проблема заключается в недостаточной проверке публичных ключей при аутентификации по протоколу SSH. Если супер кратко, то злоумышленник может установить SSH соединение не имея приватного ключа. 🤯
MTik.pro новости
CVE на последнее обновление #MikroTik подъехало: CVE-2026-67276 И это критическая уязвимость аж на 9.2 (из 10). Суть уязвимости Проблема заключается в недостаточной проверке публичных ключей при аутентификации по протоколу SSH. Если супер кратко, то злоумышленник…
Ещё из интересного:
После обновления система автоматически проверит конфигурацию на признаки компрометации. Если подозрительные изменения будут обнаружены, устройству присваивается статус Flagged, а в журнале появляется критическая запись.
Этот статус ограничит часть действий с роутером, например, невозможно будет настроить socks или добавить VPN, но можно будет их удалить.
Для отключения (разблокировки) - потребуется отключение режима через device-mode
После обновления система автоматически проверит конфигурацию на признаки компрометации. Если подозрительные изменения будут обнаружены, устройству присваивается статус Flagged, а в журнале появляется критическая запись.
Этот статус ограничит часть действий с роутером, например, невозможно будет настроить socks или добавить VPN, но можно будет их удалить.
Для отключения (разблокировки) - потребуется отключение режима через device-mode
Mikrotik
Device mode | RouterOS Manual
The device-mode feature restricts router access and limits configuration options to enhance security, available in advanced, home, basic, or ros modes depending on device type and RouterOS version. Changes require physical confirmation via power cycle or…
MTik.pro новости
Экстренные Обновления #MikroTIk #RouterOS Снова что-то серьёзное! RouterOS 7 Stable: 7.24.2 RouterOS 7 Long-term: 7.23.4 RouterOS 6 Long-term: 6.49.21 В changelog'е: This is an important security update. Most configurations are not at risk, but upgrading…
Обновление #RouterOS 7
в "long-term" канале 7.23.4 сломана, но фикс есть в следующей версии.
так что если обновлялись уже, обновляйтесь ещё раз 🤯
в "long-term" канале 7.23.4 сломана, но фикс есть в следующей версии.
так что если обновлялись уже, обновляйтесь ещё раз 🤯
#MikroTik тихо выкатил обновление с настоятельным рекомендация применить их на миллионы устройств.
С одной стороны, проблемы могут быть реальными, с другой стороны хотелось бы как всегда видеть детальный changelog.
С современными технологичнымиAI , достаточно базовых академических знаний, чтобы провести реверс инжиниринг и узнать что же исправили.
Что и сделали:
Reversing MikroTik’s Silent Patch: The RouterOS 7.23.4 Fix They Wouldn’t Explain
С одной стороны, проблемы могут быть реальными, с другой стороны хотелось бы как всегда видеть детальный changelog.
С современными технологичными
Что и сделали:
Reversing MikroTik’s Silent Patch: The RouterOS 7.23.4 Fix They Wouldn’t Explain
Nick Pratley
Reversing MikroTik's Silent Patch: The RouterOS 7.23.4 Fix They Wouldn't Explain | Nick Pratley
This was AI driven, and verified in a lab, 6 hours vs what would generally take weeks to months of work – why use your hands when you own a shovel or a post hole digger. On the 3rd of September 2026, MikroTik quietly pushed RouterOS 7.23.4 (long-term), 7.24.2…
🔥6
Новые версии #RouterOS 7
Хронология:
2026-09-03 security updates:
Исправлено 6 CVE, в том числе критические
✅ RouterOS 6.49.21 (long-term)
❌ RouterOS 7.23.4 (long-term)
❗️ RouterOS 7.24.2 (stable)
❗️ RouterOS 7.25 beta 3 (development)
2026-09-04 fix for RouterOS 7 (long-term):
исправили IPv6 DHCP (сломали в 7.23.4)
❗️RouterOS 7.23.5 (long-term)
2026-09-15 security updates:
Исправлено ещё 2 CVE
❌ RouterOS 7.23.6 (long-term)
❌ RouterOS 7.24.3 (stable)
2026-09-15 fix for LTE firmwares:
исправили работу с LTE (сломали в 7.24.3 и в 7.23.6)
✅ RouterOS 7.23.7 (long-term)
✅ RouterOS 7.24.4 (stable)
Хронология:
2026-09-03 security updates:
Исправлено 6 CVE, в том числе критические
✅ RouterOS 6.49.21 (long-term)
❌ RouterOS 7.23.4 (long-term)
❗️ RouterOS 7.24.2 (stable)
❗️ RouterOS 7.25 beta 3 (development)
2026-09-04 fix for RouterOS 7 (long-term):
исправили IPv6 DHCP (сломали в 7.23.4)
❗️RouterOS 7.23.5 (long-term)
2026-09-15 security updates:
Исправлено ещё 2 CVE
❌ RouterOS 7.23.6 (long-term)
❌ RouterOS 7.24.3 (stable)
2026-09-15 fix for LTE firmwares:
исправили работу с LTE (сломали в 7.24.3 и в 7.23.6)
✅ RouterOS 7.23.7 (long-term)
✅ RouterOS 7.24.4 (stable)
Mikrotik
MikroTik makes networking hardware and software, which is used in nearly all countries of the world. Our mission is to make existing Internet technologies faster, more powerful and affordable to wider range of users.
🔥4
MTik.pro новости
Новые версии #RouterOS 7 Хронология: 2026-09-03 security updates: Исправлено 6 CVE, в том числе критические ✅ RouterOS 6.49.21 (long-term) ❌ RouterOS 7.23.4 (long-term) ❗️ RouterOS 7.24.2 (stable) ❗️ RouterOS 7.25 beta 3 (development) 2026-09-04 fix for…
2026-09-16 security updates:
✅ RouterOS 6.49.22 (long-term)
✅ RouterOS 6.49.22 (long-term)
*) system - improve stability (includes CVE-2026-67281);👍2🔥1
Из интересных фич, которые ожидаются в следующих релизах #RouterOS 7
RouterOS 7.25rc1 (2026-10-01):
BGP / EVPN
IPv6
Monitoring
HW / Firmware
SSH / Security
Certs
Tunnels
Other
RouterOS 7.25rc1 (2026-10-01):
BGP / EVPN
*) bgp - show interface names and VRF names in BGP logs;
*) bgp - add the always-compare-med setting;
*) bgp - fix BGP unnumbered connections within a VRF;
*) evpn - publish MAC-IP routes (RT-2) for neighbors;
IPv6
*) dhcpv4-server - add ipv6-only-preferred parameter to respect option 108;
*) ipv6 - fix a failure when releasing DHCPv6 prefix delegation pools;
*) ipv6 - fix cases when address is lost after reboot if prefix was taken from pool;
*) ipv6 - fix the DNS timer in router advertisements;
*) ipv6 - ignore router advertisements received on interfaces not in the accepting list;
Monitoring
*) snmp - add an OID and logging for blacklisted program access;
*) snmp - add CAPsMAN radio data to SNMP;
*) snmp - add dynamic SNMP engine ID assignment;
*) snmp - add interface table with mtu and l2mtu OIDs;
*) snmp - add IP pool OIDs;
*) snmp - add IPv6 address and interface name to the MNDP neighbour table;
*) snmp - add OID blacklisting;
*) snmp - add OIDs for Netwatch probes;
*) snmp - add OSPF MIB tables;
*) snmp - add SHA-2 authentication for SNMPv3;
*) snmp - add transmit drop counters;
*) snmp - add VRRP status OIDs for monitoring;
*) snmp - fix the reported capability flags in LLDP-MIB;
*) snmp - fix the snmp tools timing out when authentication is used;
*) snmp - log a warning when the src-address family does not match the request;
*) snmp - remove an interface OID that should not be accessible;
*) system - remove the channel label from the RouterOS version;
HW / Firmware
*) poe-out - firmware update for 802.3at capable boards (the update will cause a brief power interruption to poe-out interfaces);
*) poe-out - firmware update for 802.3bt capable boards (the update will cause a brief power interruption to poe-out interfaces);
*) ethernet - fix link flap and unexpected reboots on RB5009;
*) ethernet - fix SFP compatibility on hAP ax S and hEX S (2025) devices;
SSH / Security
*) ssh - add a connection id to SSH log entries;
*) ssh - add host key verification for the SSH client;
*) ssh - limit server output to the client's window size;
*) ssh - show router host key fingerprint;
*) ssh - switch the default host key type to Ed25519;
*) ssh - warn users when weak RSA key is being used;
*) system - improve stability (includes CVE-2026-31431, CVE-2026-67280);
Certs
*) certificate - fix ACME certificate issuance for wildcard domains;
*) certificate - refactor certificate internal processes;
Tunnels
*) winbox - show WireGuard peer information;
*) wireguard - add the client-mtu parameter;
*) wireguard - allow referencing a peer by its name;
*) wireguard - allow unsetting the client-listen-port;
*) wireguard - improve error message reporting when adding a new peer;
*) wireguard - keep peer rx/tx counters when the peer is disabled and enabled;
*) wireguard - support comment lines in wg-import configuration files;
*) wireguard - treat empty private-key and preshared-key values as none;
*) wireguard - use the MTU value when importing a configuration;
*) wireguard - warn when an allowed-address overlaps another peer;
Other
*) tftp - add VRF support;
*) bridge - add dynamic ARP inspection;
*) bridge - add IP source guard;
*) bridge - warn about VLAN entries when vlan-filtering is disabled;
*) firewall - add NAT-related fields to CEF format logging;
🔥4
Из интересных фич, которые ожидаются в следующих релизах #RouterOS 7
RouterOS 7.26beta1 (2026-10-01):
Самое интересное
IPv6
Other
RouterOS 7.26beta1 (2026-10-01):
Самое интересное
*) cmr - add initial implementation of centralised platform for RouterOS devices, allowing updates, monitoring, alerts and other options;
*) l3hw - add VRRP hardware offloading support;
IPv6
*) dhcpv6-server - add a dns-none option to not include DNS options in responses;
*) dhcpv6-server - fix a DHCPv6 server failure when the RADIUS reply contains an empty delegated IPv6 prefix;
*) lte - fix IPv6 route not being added on modems that do not report a gateway via control interface;
*) switch - fix switch rules port matchers not working on IPv6 traffic on Atheros-based switch chips;
Other
*) ethernet - move the port bandwidth setting to the switch port menu;
*) interface - show if interface is blocked by stp or dot1x;
*) switch - add interface-list support to port isolation;
Дата‑центры больше не «неприкасаемые».
Сначала — 🔥 ДЦ Яндекса в Рязанской области. Затем — 🔥 ДЦ Яндекса в Калуге. Два крупных узла подряд — это уже повод не просто понервничать, а пересмотреть архитектуру отказоустойчивости.
«Облачные плюшки» (единое окно, автомиграция, оптимизация затрат и т. п.) выглядят удобно — но в критический момент этого оказалось недостаточно.
Самое время добавить резервирование на отдельной площадке или у другого провайдера.
————
P.S. Если вам нужна резервная площадка (виртуалки, бэкапы, bare-metal), есть варианты в не популярных городах:
5️⃣9️⃣ Пермь
6️⃣6️⃣ Екатеринбург
5️⃣2️⃣ Нижний Новгород
Особенности площадок:
✅ Доступ сразу к IPMI или гипервизору (без «красивых» веб‑панелек)
✅ Акцент на управляемость и контроль
✅ Не размещают подозрительные сервисы
✅ Помогают с настройкой и обслуживанием
❗️ Аплинки и внешние каналы не бесконечные как у Яндекса, но 10 Гбит/сек найдётся.
Пишите в личку.
Формальности ради: не реклама, а предложение пообщаться.
Сначала — 🔥 ДЦ Яндекса в Рязанской области. Затем — 🔥 ДЦ Яндекса в Калуге. Два крупных узла подряд — это уже повод не просто понервничать, а пересмотреть архитектуру отказоустойчивости.
«Облачные плюшки» (единое окно, автомиграция, оптимизация затрат и т. п.) выглядят удобно — но в критический момент этого оказалось недостаточно.
Самое время добавить резервирование на отдельной площадке или у другого провайдера.
————
P.S. Если вам нужна резервная площадка (виртуалки, бэкапы, bare-metal), есть варианты в не популярных городах:
5️⃣9️⃣ Пермь
6️⃣6️⃣ Екатеринбург
5️⃣2️⃣ Нижний Новгород
Особенности площадок:
✅ Доступ сразу к IPMI или гипервизору (без «красивых» веб‑панелек)
✅ Акцент на управляемость и контроль
✅ Не размещают подозрительные сервисы
✅ Помогают с настройкой и обслуживанием
❗️ Аплинки и внешние каналы не бесконечные как у Яндекса, но 10 Гбит/сек найдётся.
Пишите в личку.
Формальности ради: не реклама, а предложение пообщаться.
😱2🔥1👏1 1
Я понимаю, что все новости сейчас актуальнее про Яндекс, сбер, ВК ... писать, но тут #MikroTik ещё дыру закрыл в long-term и в RouterOS 6
Новость начал писать вовремя, но лежал в больничке было не до новостей, забыл.
What's new in 6.49.23 (2026-10-07):
*) system - improve stability (includes CVE-2026-84411);
What's new in 7.23.8 (2026-10-08):
*) console - fix console output of /system/identity/print being split into multiple lines (introduced in v7.23.6);
*) ethernet - improved stability when forcing unsupported link speed;
*) ipsec - fix IPsec tunnels not establishing when an address my-id is configured on the responder;
*) ospf - fix unset interface template parameters not being applied to interfaces;
*) quickset - fix the WAN interface being selected incorrectly;
*) system - improve stability (includes CVE-2026-84411);
*) system - stop the flash configuration store from growing on dynamic configuration changes;
*) wifi - fix malformed management frame information elements advertising availability of multiple 6GHz APs;
*) wifi - update radio regulatory information;
Новость начал писать вовремя, но лежал в больничке было не до новостей, забыл.
Актуальный вопрос про MikroTik сегодня почему у них сайт лежит с 503 Service Unavailable
Service temporarily down for maintenance
Типичный Сисадмин
Всё-таки уровень угрозы лютейщий так что будет не лишним подсветить.
Все версии PHP (до тех, что вышли сегодня) уязвимы.
Ваши сайты можно "взломать".
Самое простое, что вы можете сделать:
* Бэкап (всей виртуалку, например)
* Закрыть доступы из вне, которые не важны или которыми можно пока пожертвовать (вероятно, так поступили с MikroTik.com)
Отдельный "привет" ребятам из Форпост и Carbon soft, которые фанатеют по PHP 5.6, выпущенному 12 лет назад и не видят смысл обновлять ни #PHP, ни поддерживаемые ОС для своих продуктов.
Все версии PHP (до тех, что вышли сегодня) уязвимы.
Ваши сайты можно "взломать".
Самое простое, что вы можете сделать:
* Бэкап (всей виртуалку, например)
* Закрыть доступы из вне, которые не важны или которыми можно пока пожертвовать (вероятно, так поступили с MikroTik.com)
Отдельный "привет" ребятам из Форпост и Carbon soft, которые фанатеют по PHP 5.6, выпущенному 12 лет назад и не видят смысл обновлять ни #PHP, ни поддерживаемые ОС для своих продуктов.